Checkly Runtime 2021.10 with faker.js and updated Playwright

checkly

Checkly has released a new runtime version 2021.10. This is great news for anyone creating browser checks in Checkly, as we have added some new features and brought everything up to date.

What's New?

Here are some of the highlights of runtime 2021.10:

  • Playwright 1.15.2: new Headers API, mouse wheel support, new Locators API, and more.
  • Faker - We've added faker.js so you can generate fake data in your check scripts. Checkly users requested this. See an example script here.

At Checkly, we try to release an updated runtime on a regular cadence. We release runtimes for two reasons: to bring you new features that you can use in your checks and to update packages with the latest security fixes. Quarterly releases are our ideal goal, but more importantly, we want to bring you the best feature set possible, so our releases are not to a strict schedule.

What are runtimes?

Runtimes give you the tools you need to build your checks. Checkly allows you to use JavaScript code in your Browser checks and in the optional setup & teardown scripts that you can add to your API checks.

This JavaScript code executes in a runtime environment that is managed by Checkly. This environment has access to specific Node.js versions and NPM packages, like the "latest Playwright version on Node 14". We call these environments runtimes.

Getting Started

All new Checkly accounts will use the latest runtime by default. For existing accounts, you can configure the default in the account settings page.

You can also override the default runtime on a per-check or per-group level. See the documentation for details.

Here is the list of everything included in runtime 2021.10:

      "dependencies": {
        "aws4": "1.11.0",
        "axios": "0.23.0",
        "btoa": "1.2.1",
        "chai": "4.3.4",
        "chai-string": "1.5.0",
        "crypto-js": "4.1.1",
        "expect": "27.3.1",
        "faker": "5.5.3",
        "form-data": "4.0.0",
        "jsonwebtoken": "8.5.1",
        "lodash": "4.17.21",
        "mocha": "9.1.3",
        "moment": "2.29.1",
        "node": "14.x",
        "playwright": "1.15.2",
        "puppeteer": "10.4.0",
        "request": "2.88.2",
        "request-promise": "4.2.2",
        "uuid": "8.3.2"
      }
checkly

Recent posts

Donโ€™t miss any updates

No fluff, all relevant product updates & long form content. ๐Ÿ